fbpx

204,593+ downloads

0
  Wednesday, 29 April 2020
  2 Replies
  2.5K Visits
  Subscribe
Dear Sellacious Community,

Today I tried to create a marketplace and the installation worked without any problems, but then I wanted to create a product and display the products but every time this error comes up:
"Oooops, something went wrong!
Class 'SQLite3' not found,
If you believe this is a bug,
please contact the site administrator."
What can I do about it.
I hope for a quick answer

Yours sincerely, Yannick
2 years ago
·
#4324
Accepted Answer
Hi Yannick

SQLite3 is a PHP service, so it may be that on your configuration the extension is not enabled yet. So, had a similar problem and this was the fix (works for Windows XAMPP but should be same for others)

find php.ini file
Open in Notepad++ or some other clean text editor
open a search for SQLite3 and you should find a line like this:
;extension=sqlite3
remove the comment (in this case the semicolon)
so the line reads extension=sqlite3
Save and Close
Log out of sellacious, Joomla and if using XAMPP, close Mysql and Apache, then re-open.

that should fix it
2 years ago
·
#4324
Accepted Answer
Hi Yannick

SQLite3 is a PHP service, so it may be that on your configuration the extension is not enabled yet. So, had a similar problem and this was the fix (works for Windows XAMPP but should be same for others)

find php.ini file
Open in Notepad++ or some other clean text editor
open a search for SQLite3 and you should find a line like this:
;extension=sqlite3
remove the comment (in this case the semicolon)
so the line reads extension=sqlite3
Save and Close
Log out of sellacious, Joomla and if using XAMPP, close Mysql and Apache, then re-open.

that should fix it
2 years ago
·
#4497
ATTENTION!

even if you are running sqlite3 as a service you may encounter corruptions in the database especially if running a multi language site.

So, as well as running sqlite3 as a service, it is important to look out for the setting in php.ini that controls the defensive mode

in XAMPP, this is in xampp/php/php.ini at Line 1037

remove the ';' semi-colon from the line so it reads:

sqlite3.defensive = 1

Now, if you are running Sellacious 2.0.0 beta1 on a dev server, make sure to ask the hosting that this defensive setting is enabled. Many hosts will run sqlite3, but not necessarily give you access to php.ini
Some will run sqlite3 but NOT in defensive mode

So, answer for dev cycle is to run on XAMPP with these settings and that *should* help
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!
  • +1 (408) 821-8283
  • Email hello@sellacious.com