fbpx
0
Hi,
On Upgrading to v2.0.0-beta3 , I am getting the following error, when site is being opened.

HY000
SQLSTATE[HY000]: General error: 1 near "(": syntax error

Please help me to fix this error.

Thanks & Regards,
Arshad
Attachments (1)
References
  1. https://new.oplmart.com
Replies (11)
Arshad Hussain Accepted Answer Pending Moderation
  1. Replied more than a month ago
  2. #Permalink
Hi,
On commenting the following line in .../libraries/sellacious/objects/Sellacious/Cache/Storage/Sqlite

// $query->clear('select')->select('SUM(1) OVER ()'); // arshad

the error disappeared.
But the page is not displaying properly. I don't think this is the proper fix. Please suggest.
Moreover, I am also getting the following error in other pages.
500
Layout default_price not found.

Please consider this in priority.
Thanks & regards,
Arshad
Indresh Maurya Accepted Answer Pending Moderation
Team
  1. Replied more than a month ago
  2. #Permalink
Hi Arshad,
Do not comment any code, you just need to rebuilt cache and index after that.
But prior to that pls make sure your system fulfils these requirements https://www.sellacious.com/documentation-v2#/learn/basics/system-requirements

For pricing related error make sure there are not layout override in you template.

Thanks
Arshad Hussain Accepted Answer Pending Moderation
  1. Replied more than a month ago
  2. #Permalink
Hi Andresh
Thanks for the support. I tried your suggestion. I get the following notification on rebuilding cache, but the issue remains intake.
Success The cache rebuild process was queued up to run in the background.

Regarding pricing related issue, please tell me how will I do it it template.
Regards,
Arshad
Nearest Market Accepted Answer Pending Moderation
  1. Replied more than a month ago
  2. #Permalink
Typo : not "intake", it is unfixed.
Indresh Maurya Accepted Answer Pending Moderation
Team
  1. Replied more than a month ago
  2. #Permalink
Hi,
Can you tell me that what template is on your website and what is the version of sellacious?

also your system should fulfil these requirements https://www.sellacious.com/documentation-v2#/learn/basics/system-requirements
this is must, specially sqlite version an php executable cli.

thanks
Arshad Hussain Accepted Answer Pending Moderation
  1. Replied more than a month ago
  2. #Permalink
Hi,
Template on my website is squick and the version of the sellacious upgraded to the pkg_sellacious_v2.0.0-beta3.zip and
pkg_sellacious_extended_v2.0.0-beta3.zip. The system requirements are fulfilled, except the sqlite3 which shows the correct version on command line after upgrading it, but it still showing the old version in phpinfo query as you will find on clicking the followinf link.
https://new.oplmart.com/phpinfo.php

Please consider this priority.

Thanks & Regards,
Arshad
Indresh Maurya Accepted Answer Pending Moderation
Team
  1. Replied more than a month ago
  2. #Permalink
Hi,
Thats exactly what is causing the issue, pls contact your server provider and upgrade sqlite version 3.25.2 or later version.
It should show in phpinfo too.
Thanks
Arshad Hussain Accepted Answer Pending Moderation
  1. Replied more than a month ago
  2. #Permalink
Hi Indresh,
Thank you so much. We manage our servers ourselves. It is true that phpinfo still shows the older version of sqlite, but if this would be the cause of the error in question, then fresh installation of the version also be having this error. Yes, the fresh installation is working fine as you can check in the following link although the phpinfo even here shows the older version of Sqlite3.

https://nearest.oplmart.com

https://nearest.oplmart.com/phpinfo.php

Thanks & Regards,
Arshad
Indresh Maurya Accepted Answer Pending Moderation
Team
  1. Replied more than a month ago
  2. #Permalink
Hi,
Is this a sellacious_v2.0.0-beta3 ? because this requirement is for sellacious_v2.0.0-beta3. fresh installtion work fine because it is sellacious_v2.0.0-beta1.
if otherwise let me know.
Thanks
Arshad Hussain Accepted Answer Pending Moderation
  1. Replied more than a month ago
  2. #Permalink
Hi Indresh,
Thank you so much. You are right. Fresh installed sellacious is having version sellacious_v2.0.0-beta1 with quickstart bundled. Under the situation, we request you to guide us in sqlite3 version issue. We have already upgraded the sqlite3 to 3.34.1 version and it s appearing in using command, Sqlite3 -- version and in python as follows:-
# pythone
>> import Sqlite3
>> Sqlite3.sqlite_versio
3.34.1

But in phpinfo it is still showing the older version 3.7.17

Thanks & Regards
Arshad Hussain

Hi,
Is this a sellacious_v2.0.0-beta3 ? because this requirement is for sellacious_v2.0.0-beta3. fresh installtion work fine because it is sellacious_v2.0.0-beta1.
if otherwise let me know.
Thanks
Indresh Maurya Accepted Answer Pending Moderation
Team
  1. Replied more than a month ago
  2. #Permalink
Hi,
This is server related issue so Kindly send this issue to your server provider, i think sqlite version is not correctly updated for your instance.
Thanks.
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.
Support is Offline
Support Hours
Monday To Saturday
From 09:00 To 21:00 IST
Sellacious Time 00:00:00

Login

?
?
< !-- Calendly badge widget begin -->< !-- Calendly badge widget end -->< !-- Google Tag Manager (noscript) -->< !-- End Google Tag Manager (noscript) -->< !-- Start of HubSpot Embed Code -->< !-- End of HubSpot Embed Code -->