fbpx
0
Could not connect to PDO: could not find driver

Frontend and backend show this message after installation of joomla quickstart version 2.00 beta 1.

- Server: Ubuntu 18.04
- PHP version 7.4
- mysql Ver 14.14
- ZIP enabled, Libzip library version 1.7.3
- cURL enabled, cURL Information 7.58.0
- sqlite3 --version 3.22.0 (I see Doc req. say min. 3.25.x, does it matter? I cannot find how to upgrade sqlite3 to higher version on Ubuntu 18.04, any idea howto?
- PHP: Safe Mode = Off
- PHP: shell_exec = ? => No record of shell_exec in php.ini. It is not listed under disable_functions, so I think it is enabled
- PHP: passthru = ? Same as for shell_exec
- PHP: magic_quotes_gpc = Off
- PHP: max_execution_time = 600
- PHP: upload_max_filesize = 256MB
- PHP: post_max_size = 256MB
- PHP: memory_limit = 256MB

PDO settings, see attached snip from joomla backend (enabled, drivers: mysql).

Do you have any idea how to solve this?
Attachments (1)
Replies (4)
Indresh Maurya Accepted Answer Pending Moderation
Team
  1. Replied 2 weeks ago
  2. #Permalink
Hi,
Please make sure your system is fulfilling these requirements https://www.sellacious.com/documentation-v2#/learn/basics/system-requirements.

On pdo driver issue it seems like the extension which being called is not present in the system. kindly inform this to your server provider and get it installed.

On sqlite version- yes our system requires Sqlite 3.25.2+ as mentioned in the doc.


Thanks.
Attachments (1)
ILU3 Accepted Answer Pending Moderation
  1. Replied 2 weeks ago
  2. #Permalink
Thank you for quick reply Indresh, very much appreciated.

I searched a lot around and seems there is no way to upgrade Sqlite3.22.x to a higher version on Ubuntu server 18.04 without breaking the system. So my conclusion is that Sellacious is not compatible with Ubuntu Server 18.04, do you agree?

However, looks like Ubuntu server 20.04 is shipped with Sqlit3.31.x. Do you know if Sellacious is compatible with Ubuntu Server 20.04 LTS or if there are known issues with it?
Indresh Maurya Accepted Answer Pending Moderation
Team
  1. Replied 2 weeks ago
  2. #Permalink
Hi,

As per our knowledge we do not have any issue with Ubuntu server 20.04 as far as requirements are met, so if possible you can try that one. We will be helping if any issue is faced later on.

Thanks.
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.
Support is Offline
Support Hours
Monday To Saturday
From 09:00 To 21:00 IST
Sellacious Time 00:00:00

Login

?
?